Scheduled for May 21, 2025 at 10.00 – 10.02
Affects
ftp.travelclearing.com
Under maintenance from 10:00 AM to 10:02 AM
Completed
May 21, 2025 at 10.02Completed
May 21, 2025 at 10.02Maintenance completed successfully.
In progress
May 21, 2025 at 10.00In progress
May 21, 2025 at 10.00Maintenance is now in progress
Planned
May 21, 2025 at 10.00Planned
May 21, 2025 at 10.00We are planning for a scheduled maintenance during that time.